MLflow SHAP load_explainer Deserialization of Untrusted Data Remote Code Execution Vulnerability
Affects MLflow versions before 3.17.0 when loading SHAP explainers with load_explainer. Fixed in 3.17.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.17.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Target must visit a malicious page or open a malicious file Affected MLflow versions prior to 3.17.0 (fixed in 3.17.0)
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.8/10CVSS 7.8
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-118627 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.8 (high) and affects MLflow; fixed in 3.17.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.17.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
MLflow, an open-source machine learning platform, is affected through its SHAP explainer model loading functionality. An attacker could exploit this to run arbitrary code with the privileges of the current user, but only if a victim visits a malicious page or opens a malicious file.
Read the original description
MLflow SHAP load_explainer Deserialization of Untrusted Data Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MLflow. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the loading of SHAP explainer models. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current user. Was ZDI-CAN-30301.
What to do
Check whether your setup matches what the bug needs.
Target must visit a malicious page or open a malicious file Affected MLflow versions prior to 3.17.0 (fixed in 3.17.0)Upgrade to a fixed version: 3.17.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- MLflow MLflow
3.11.2.dev0
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-118627
Is CVE-2026-118627 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Loading an explainer through MLflow's SHAP load_explainer function deserializes untrusted data, which can run code in the context of the current user. The target must visit a malicious page or open a malicious file for this to happen.Source: zerodayinitiative.com
Which versions are affected by CVE-2026-118627?
MLflow: version 3.11.2.dev0.Source: cve.now feed data
Am I affected, and how do I check?
MLflow versions prior to 3.17.0 are affected. To check, run mlflow --version or pip show mlflow in the environment where MLflow runs.Source: zerodayinitiative.com
How do I fix CVE-2026-118627?
Upgrade MLflow to 3.17.0 or later, the fixed version named in the advisory.Source: zerodayinitiative.com
Why do the sources disagree?
The description says a remote attacker can exploit this, but the CVSS vector is scored as AV:L, which means local access. The sources conflict on whether the attack vector is remote or local.Source: zerodayinitiative.com