MLflow PickleEvaluationArtifact Deserialization of Untrusted Data Remote Code Execution Vulnerability
Fixed in MLflow 3.13.0. No vendor severity rating is published for this vulnerability.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.13.0
- Who is exposed
- Specific setups only
Do first: Upgrade to a fixed version: 3.13.0.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.8/10CVSS 7.8
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-118623 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.8 (high) and affects MLflow; fixed in 3.13.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.13.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
MLflow, an open-source machine learning platform, is affected by this vulnerability. An attacker could exploit it by tricking a user into visiting a malicious page or opening a malicious file, allowing arbitrary code to run within the context of the MLflow process.
Read the original description
MLflow PickleEvaluationArtifact Deserialization of Untrusted Data Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of MLflow. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of pickle files. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-29513.
What to do
Upgrade to a fixed version: 3.13.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- MLflow MLflow
3.10.1
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-118623
Is CVE-2026-118623 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Loading untrusted serialized data through PickleEvaluationArtifact can run attacker-supplied code inside the current MLflow process. The advisory describes this as code execution in the context of the running process.Source: zerodayinitiative.com
Which versions are affected by CVE-2026-118623?
MLflow: version 3.10.1.Source: cve.now feed data
Am I affected, and how do I check?
The checked facts do not list affected version ranges or specific setups. To check an installation, run `mlflow --version` or `pip show mlflow` and compare the result with the fixed version, 3.13.0.Source: zerodayinitiative.com
How do I fix CVE-2026-118623?
Upgrade MLflow to 3.13.0 or later, which contains the fix.Source: zerodayinitiative.com