Skip to main content
← Vulnerabilities

AshAuthentication brute_force_strategy does not limit sign-in and request actions defined on the resource

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

6.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 5.0.0-rc.16
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.0.0-rc.16.

33Pcve.now Index 33 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Data gap: No advisory context yet
  • Reach10/20Affects Hex packages
  • Severity6.3/10CVSS 6.3
  • No patch0/5No signal

What would change the score

  • Would score about 78 if added to CISA KEV
  • Would score about 73 if CISA's SSVC rates exploitation active
  • Would score about 38 if advisories confirm default setups are exposed

CVE-2026-118505 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects ash_authentication; fixed in 5.0.0-rc.16.

Published
Last modified
Published
Not listed in CISA KEV
33/100 · provisional
Fix
Fixed in 5.0.0-rc.16
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

AshAuthentication, an Elixir library for adding authentication to Ash resources, is affected in versions from 5.0.0-rc.4 up to (but not including) a fixed release. Because the brute-force protection setting silently failed to apply to password, magic link, and one-time password sign-in and reset actions that a resource defines itself, an unauthenticated attacker could make unlimited password or one-time code guesses against user accounts.

Read the original description

Improper Restriction of Excessive Authentication Attempts vulnerability in team-alembic ash_authentication allows an unauthenticated attacker to guess passwords and one-time passwords without limit. The password, magic link and OTP strategies enforce brute_force_strategy by adding a preparation only to the actions they generate. When the resource defines one of those actions itself, the strategy uses it as written and nothing checked that it carried the preparation, so the setting compiled and applied no limit. The generators produce exactly this: mix ash_authentication.install writes sign_in_with_password, request_password_reset_token and request_magic_link, mix ash_authentication.upgrade then adds brute_force_strategy to those strategies, and mix ash_authentication.add_strategy.otp writes its OTP actions without the preparation. Separately, with registration_enabled? true the OTP sign-in is a create action, which preparations do not run on, so brute_force_strategy {:preparation, module} never applied to it. This issue affects ash_authentication: from 5.0.0-rc.4 before 5.0.0-rc.16.

What to do

  • Upgrade to a fixed version: 5.0.0-rc.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • ash_authenticationHex

    From 5.0.0-rc.4 · fixed in 5.0.0-rc.16

  • team-alembic/ash_authentication

    Version range not reported

  • ash_authenticationHex

    From 5.0.0-rc.4 · fixed in 5.0.0-rc.16

Evidence 5

  1. Advisory
  2. Patch
  3. Repository
  4. Link
  5. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-118505

Is CVE-2026-118505 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-118505?

ash_authentication (Hex): from 5.0.0-rc.4 before 5.0.0-rc.16. ash_authentication (Hex): from 5.0.0-rc.4 before 5.0.0-rc.16.Source: cve.now feed data

How do I fix CVE-2026-118505?

Upgrade to a fixed version: 5.0.0-rc.16.Source: cve.now feed data