WordPress MasterStudy LMS plugin <= 3.7.55 - PHP Object Injection vulnerability
MasterStudy LMS plugin by Stylemix, versions up to and including 3.7.55, are affected. The fix is in version 3.7.56.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.7.56
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The MasterStudy LMS plugin for WordPress, a learning management system used to build online courses, is affected by this vulnerability. An attacker with a low-privilege subscriber account could exploit it to inject malicious serialized PHP objects, potentially leading to code execution, data access, or site compromise.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Subscriber PHP Object Injection in MasterStudy LMS <= 3.7.55 versions.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- masterstudy-lms-learning-management-system
through 3.7.55
References 1
Questions about CVE-2026-118090
What does this mean?
The flaw is a PHP Object Injection issue. Attackers can manipulate how the site processes data to run harmful actions on the server.Source: patchstack.com
Am I affected, and how do I check?
Affected plugin versions are MasterStudy LMS up to and including 3.7.55. The installed version is shown on the WordPress Plugins page, where it can be compared against that range.Source: patchstack.com
What should I do about it?
Update MasterStudy LMS to version 3.7.56 or later.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data