WordPress Product Feed Manager plugin <= 7.14.1 - PHP Object Injection vulnerability
Affects the RexTheme Product Feed Manager WordPress plugin, version 7.14.1 and earlier. Fixed in 7.14.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 7.14.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The WordPress Product Feed Manager plugin is affected, a tool used to generate product feeds for online stores. An attacker with shop manager access could exploit a PHP object injection flaw to potentially run malicious code or manipulate data on the affected site.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Shop manager PHP Object Injection in Product Feed Manager <= 7.14.1 versions.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- best-woocommerce-feed
through 7.14.1
References 1
Questions about CVE-2026-118089
What does this mean?
This is a PHP Object Injection flaw: the plugin can be made to process data in a way that lets an attacker run harmful actions on the server.Source: patchstack.com
Am I affected, and how do I check?
The RexTheme Product Feed Manager plugin, version 7.14.1 and earlier, is affected. To check a site, look at the plugin version listed on the WordPress Plugins page.Source: patchstack.com
What should I do about it?
Update the plugin to version 7.14.2 or later, which the advisory says resolves the vulnerability.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data