Skip to main content
← All vulnerabilities
CVE-2026-116851

WordPress eCommerce Product Catalog plugin <= 3.6.5 - Cross Site Scripting (XSS) vulnerability

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 3.6.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The WordPress eCommerce Product Catalog plugin is affected by this vulnerability. An attacker who does not need to log in can inject malicious scripts that run in the browsers of people who visit the affected pages.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Unauthenticated Cross Site Scripting (XSS) in eCommerce Product Catalog <= 3.6.5 versions.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • ecommerce-product-catalog

    through 3.6.5

References 1

patchstack.com

FAQ

Questions about CVE-2026-116851

What does this mean?

The plugin does not properly neutralize user-supplied input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com

Am I affected, and how do I check?

Versions of the WordPress eCommerce Product Catalog plugin up to and including 3.6.5 are affected. To check, look at the plugin version shown on the WordPress Plugins screen.Source: patchstack.com

What should I do about it?

Update the plugin to version 3.6.6 or later, which contains the fix.Source: patchstack.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data