Skip to main content
← All vulnerabilities
CVE-2026-116847

WordPress Mang Board WP plugin <= 2.4.6 - Cross Site Scripting (XSS) vulnerability

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 2.4.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Mang Board WP plugin for WordPress is affected by this vulnerability. An unauthenticated attacker could exploit it to inject malicious scripts into pages, which could run in the browsers of other users who view them.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Unauthenticated Cross Site Scripting (XSS) in Mang Board WP <= 2.4.6 versions.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • mangboard

    through 2.4.6

References 1

patchstack.com

FAQ

Questions about CVE-2026-116847

What does this mean?

The plugin does not properly sanitize input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack user accounts.Source: patchstack.com

Am I affected, and how do I check?

Mang Board WP plugin versions up to and including 2.4.6 for WordPress are affected. To check, look at the installed plugin version in the WordPress Plugins screen or the plugin header.Source: patchstack.com

What should I do about it?

Update the Mang Board WP plugin to version 2.4.7 or later.Source: patchstack.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data