WordPress VikRentCar plugin <= 1.4.9 - Cross Site Scripting (XSS) vulnerability
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.4.10
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The VikRentCar plugin for WordPress is affected by this vulnerability, which allows unauthenticated attackers to inject malicious scripts into pages. If a user visits a crafted page or link, those scripts can run in their browser, potentially enabling session hijacking, credential theft, or unwanted actions on the affected site.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Unauthenticated Cross Site Scripting (XSS) in VikRentCar <= 1.4.9 versions.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- vikrentcar
through 1.4.9
References 1
Questions about CVE-2026-116405
What does this mean?
The plugin does not properly sanitize some input, so an attacker can inject malicious scripts that run in visitors' browsers. According to the advisory, these scripts can steal visitor data or hijack accounts.Source: patchstack.com
Am I affected, and how do I check?
VikRentCar plugin version 1.4.9 and earlier for WordPress are affected. To check, look at the plugin version shown on the WordPress Plugins page or in the plugin's header information.Source: patchstack.com
What should I do about it?
Update the VikRentCar plugin to version 1.4.10 or later, which the advisory says resolves the vulnerability.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data