Skip to main content
← All vulnerabilities
CVE-2026-116165EUVD-2026-109426GHSA-QJ5Q-P3H8-4R25GHSA-QMG9-M772-5RM7

Parse Server 9.0.0 before 9.10.4-alpha.4 Unauthenticated Class Schema Deletion on MongoDB

Affects Parse Server before 8.6.101 and 9.0.0 before 9.10.4-alpha.4 on MongoDB deployments. Fixed in 8.6.101 and 9.10.4-alpha.4. The vendor gives no separate severity rating.

Published
Last modified
published
Not listed in CISA KEV
Unclear
Fix
Fixed in 9.10.4-alpha.4, 8.6.101
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server before 8.6.101 and 9.0.0 before 9.10.4-alpha.4 contains a missing authorization vulnerability on MongoDB deployments that lets clients without the master key delete the stored schema of any class. Unauthenticated attackers can send REST API delete requests targeting the internal _SCHEMA collection to remove field definitions, class-level permissions, and protected fields, exposing data to unauthorized reads and modifications.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.10.4-alpha.4

  • parse-community parse-server

    fixed in 8.6.101

References 3

GitHub · parse-community/parse-server

vulncheck.com

GitHub · mehmet-emir-eroglu/CVE-2026-116165

FAQ

Questions about CVE-2026-116165

What does this mean?

On MongoDB deployments, a client without the master key can delete the stored schema of any class. Deleting it removes field definitions, class-level permissions and protected fields, so data those protected may become readable and modifiable by any client.Source: github.com, vulncheck.com

Am I affected, and how do I check?

Parse Server before 8.6.101, and 9.0.0 before 9.10.4-alpha.4, when the deployment uses MongoDB. To check, compare your Parse Server version with these ranges and confirm which database your deployment uses.Source: github.com, vulncheck.com

What should I do about it?

Upgrade to Parse Server 8.6.101 or later on the 8.x line, or to 9.10.4-alpha.4 or later on the 9.x line.Source: github.com, vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. Public exploit code exists (a proof of concept on GitHub).Source: cve.now feed data