Skip to main content
← All vulnerabilities
CVE-2026-115907EUVD-2026-109984GHSA-9HJ8-73FH-9963

zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size

Affects the zip and zip2 crates from 5.1.0 before 9.0.0 when the legacy-zip feature is enabled. The fixed version is 9.0.0.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 9.0.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

The zip library for Rust, when built with its legacy-zip feature enabled, is affected by this flaw. A specially crafted ZIP archive can make the program crash during extraction, which could stop an archive-processing service.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

zip is a zip library for Rust that supports reading and writing simple ZIP files. From 5.1.0 until 9.0.0, applications built with the legacy-zip feature can reserve output capacity from an attacker-controlled ZIP64 uncompressed size before validating the compressed stream. The ShrinkDecoder path in src/legacy/shrink.rs can panic with a capacity overflow during ZipArchive::extract, and the Reduce and Implode decoders contain the same unbounded preallocation pattern. An unhandled panic can terminate an archive-processing service. This issue is fixed in version 9.0.0.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • zip-rs zip2

    From 5.1.0 · fixed in 9.0.0

  • zipcrates.io

    From 5.1.0 · fixed in 9.0.0

References 4

GitHub · zip-rs/zip2

FAQ

Questions about CVE-2026-115907

What does this mean?

The legacy Shrink, Reduce and Implode decoder trusts a ZIP64 uncompressed size that the archive sets, and that size can be set independently of the real payload. An unhandled panic (capacity overflow) can then terminate the archive-processing process, causing denial of service.Source: github.com

Am I affected, and how do I check?

Versions from 5.1.0 up to but not including 9.0.0 of the zip and zip2 crates. The exposed setup needs the legacy-zip feature enabled and use of ZipArchive::extract() on ZIP64 entries. Check the zip version in the lock file and whether legacy-zip appears among the enabled features.Source: github.com

What should I do about it?

Upgrade the zip or zip2 crate to 9.0.0 or later.Source: github.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data