Skip to main content
← Vulnerabilities

Report Deserialization Code Execution

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.4CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 2023.8.13, 2025.12.1, 2026.0.1
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 2023.8.13, 2025.12.1, 2026.0.1.

12Pcve.now Index 12 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure3/25Reachable over the network · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.4/10CVSS 9.4
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 31 if advisories confirm default setups are exposed

CVE-2026-115731 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.4 (critical) and affects Puppet Enterprise; fixed in 2023.8.13, 2025.12.1 and 2026.0.1.

Published
Last modified
Published
Not listed in CISA KEV
12/100 · provisional
Fix
Fixed in 2023.8.13, 2025.12.1, 2026.0.1
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Puppet Server's report-processing code is affected by a deserialization flaw that lets a client holding a CA-signed agent certificate run arbitrary code on the server as its service user. If the certificate authority autosigns requests without strong verification, an unauthenticated network attacker could obtain such a certificate and exploit this.

Read the original description

Deserialization of untrusted data in the report-processing code of Puppet, as used by Puppet Server, in the affected releases, allows a client that holds any CA-signed agent certificate to execute arbitrary code on the Puppet Server as its service user by submitting a report containing a crafted rich-data type via PUT request. Where the certificate authority autosigns requests without strong verification, an unauthenticated network attacker can obtain such a certificate.

What to do

  • Upgrade to a fixed version: 2023.8.13, 2025.12.1, 2026.0.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated
  4. Posted on X by cve.now

Affected versions

  • Perforce Puppet Enterprise

    From 2023.8.0 · fixed in 2023.8.13; From 2025.0.0 · fixed in 2025.12.1; From 2026.0.0 · fixed in 2026.0.1

Evidence 2

  1. Link
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-115731

Is CVE-2026-115731 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-115731?

Puppet Enterprise: from 2023.8.0 before 2023.8.13; from 2025.0.0 before 2025.12.1; from 2026.0.0 before 2026.0.1.Source: cve.now feed data

How do I fix CVE-2026-115731?

Upgrade to a fixed version: 2023.8.13, 2025.12.1, 2026.0.1.Source: cve.now feed data