Skip to main content
← Vulnerabilities

Improper Certificate Validation in Elastic Docker Images Leading to Interception of TLS Connections

Affects official Elastic Docker images 8.0.0 to 8.19.23, 9.0.0 to 9.4.8, and 9.5.0 to 9.5.5 where TLS uses the image's default trust store. Fixed in 8.19.24, 9.4.9, and 9.5.6.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.4HighCNA
Exploited
No known exploitation
Fix
Fixed in 8.19.24, 9.4.9, 9.5.6
Who is exposed
Default setups

Do first: Check every install: default setups are affected.

30Pcve.now Index 30 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure22/25Default setups, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.4/10CVSS 7.4, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active

CVE-2026-115714 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.4 (high) and affects Elastic Docker images; fixed in 8.19.24, 9.4.9 and 9.5.6.

Published
Last modified
Published
Not listed in CISA KEV
30/100 · provisional
Default setups
Fix
Fixed in 8.19.24, 9.4.9, 9.5.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Elastic Docker images for APM Server, the Beats family (Auditbeat, Filebeat, Heartbeat, Metricbeat, Packetbeat), Elastic Agent including Fleet Server and Cloudbeat, Logstash, Elastic connectors, Universal Profiling, and Elastic Maps Server are affected because their bundled operating system certificate authority list includes certificates tied to compromised intermediate keys. An attacker positioned between these products and a remote server could impersonate that server and intercept or modify TLS-protected traffic.

Read the original description

Improper Certificate Validation (CWE-295) in the operating system certificate bundle shipped in the Docker images of APM Server; Auditbeat, Filebeat, Heartbeat, Metricbeat and Packetbeat; Elastic Agent, including Fleet Server and Cloudbeat; Logstash, for TLS connections that use the operating system certificate bundle; Elastic connectors; Universal Profiling (host agent, collector and symbolizer); and Elastic Maps Server. This certificate bundle, a dependency of these products (Dependency on Vulnerable Third-Party Component, CWE-1395), could allow an attacker to intercept or modify TLS-protected traffic via Signature Spoofing by Key Theft (CAPEC-474). The certificate bundle includes root certificate authorities that signed eight eMudhra intermediate certificate authorities whose private keys are compromised. Anyone with these keys can issue a certificate for any host name that these products accept as trusted. Exploitation requires an attacker in a network position between the product and the remote party, who presents a certificate issued with one of the compromised keys.

What to do

  • Check every install: default setups are affected.

  • Upgrade to a fixed version: 8.19.24, 9.4.9, 9.5.6.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Elastic Elastic Docker images

    From 8.0.0 · through 8.19.23; From 9.0.0 · through 9.4.8; From 9.5.0 · through 9.5.5

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-115714

Is CVE-2026-115714 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The image does not properly validate certain TLS certificates. An attacker presenting certificates issued with compromised eMudhra intermediate CA keys could intercept or modify TLS-protected traffic for any host name the product trusts.Source: discuss.elastic.co

Which versions are affected by CVE-2026-115714?

Elastic Docker images: from 8.0.0 through 8.19.23; from 9.0.0 through 9.4.8; from 9.5.0 through 9.5.5.Source: cve.now feed data

Am I affected, and how do I check?

Official Elastic Docker images from 8.0.0 up to 8.19.23, 9.0.0 up to 9.4.8, and 9.5.0 up to 9.5.5 are affected. The issue applies to TLS connections that use the operating system default trust store in the image, with no specific certificate authorities configured for that connection. Check the image version in use and whether those connections have specific certificate authorities configured.Source: discuss.elastic.co

How do I fix CVE-2026-115714?

Upgrade to the fixed version on the same release line: 8.19.24, 9.4.9, or 9.5.6. No workaround is listed in the advisory.Source: discuss.elastic.co