Skip to main content
← Vulnerabilities

Apache ZooKeeper: Unbounded recursion in snapshot serialization allows a client to render the server unrecoverable

Affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6, where clients permitted to create znodes can crash snapshotting. Fixed in 3.8.8 and 3.9.7.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.8.8, 3.9.7
Who is exposed
Default setups

Do first: Check every install: default setups are affected.

44Pcve.now Index 44 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure25/25Default setups, CISA rates it automatable
  • Reach10/20Affects Maven packages
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 84 if added to CISA KEV
  • Would score about 79 if CISA's SSVC rates exploitation active

CVE-2026-115448 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Apache ZooKeeper; fixed in 3.8.8 and 3.9.7.

Published
Last modified
Published
Not listed in CISA KEV
44/100 · provisional
Default setups
Fix
Fixed in 3.8.8, 3.9.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Apache ZooKeeper is affected: a remote client, without logging in, can create a deeply nested chain of znodes, which the default open root ACL allows, and crash the server while it takes a snapshot. The server then fails again on every restart, so it cannot return to service, and recovery may cause data loss.

Read the original description

Uncontrolled recursion in Apache ZooKeeper. The server serializes its data tree to a snapshot by recursing one stack frame per znode level, with no depth bound. A client permitted to create znodes (the default root ACL is open) can build a chain of nested znodes deep enough that taking a snapshot exhausts the JVM stack and kills the snapshot thread; sizes stay within jute.maxbuffer, so existing limits do not prevent it. This is a denial of service that becomes persistent: on restart the server rebuilds the deep tree from its transaction log and fails again while taking the startup snapshot, so it does not return to service, and recovery can entail data loss. The same log affects a leader and its followers, so it can spread across an ensemble. This issue affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6. Users are recommended to upgrade to 3.8.8 or 3.9.7, which fix the issue. As a workaround, use ACLs and authentication to restrict znode creation rather than relying on the default open root ACL.

Impact

  • Widely used

    175 packages depend on org.apache.zookeeper:zookeeper.Source: deps.dev

What to do

  • Check every install: default setups are affected.

  • Upgrade to a fixed version: 3.8.8, 3.9.7.

  • Workaround: Use ACLs and authentication to restrict znode creation rather than relying on the default open root ACL.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • org.apache.zookeeper:zookeeperMaven

    From 3.9.0 · through 3.9.7; From 3.8.0 · through 3.8.8

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-115448

Is CVE-2026-115448 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A deeply nested chain of znodes can exhaust the JVM stack when the server takes a snapshot, which kills the snapshot thread. On restart the server fails again while taking its startup snapshot, so it cannot return to service, and recovery can entail data loss.Source: openwall.com

Which versions are affected by CVE-2026-115448?

org.apache.zookeeper:zookeeper (Maven): from 3.9.0 through 3.9.7; from 3.8.0 through 3.8.8.Source: cve.now feed data

Am I affected, and how do I check?

Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6 are affected. The setup involves a client permitted to create znodes with the default open root ACL, and a deeply nested znode chain must exist. Check the installed ZooKeeper version to see which range it falls in.Source: openwall.com

How do I fix CVE-2026-115448?

Upgrade to 3.8.8 or 3.9.7, which fix the issue. Until then, use ACLs and authentication to restrict znode creation rather than relying on the default open root ACL.Source: openwall.com