Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
Affects Elasticsearch 8.10.0 through 8.19.23, 9.0.0 through 9.4.8, and 9.5.0 through 9.5.5 on nodes with the remote cluster server interface enabled. Fixed in 8.19.24, 9.4.9, and 9.5.6.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 8.19.24, 9.4.9, 9.5.6
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Elasticsearch nodes with the remote cluster server interface enabled Affected 8.x versions from 8.10.0 up to and including 8.19.23
- Exploitation0/40No signal
- Exposure15/25Specific setups only, CISA rates it automatable
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.5/10CVSS 7.5
- No patch0/5No signal
What would change the score
- Would score about 73 if added to CISA KEV
- Would score about 68 if CISA's SSVC rates exploitation active
CVE-2026-115290 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.5 (high) and affects Elasticsearch; fixed in 8.19.24, 9.4.9 and 9.5.6.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 23/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 8.19.24, 9.4.9, 9.5.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Elasticsearch, a search and analytics engine, is affected by this vulnerability. An unauthenticated attacker with network access to a node's remote cluster interface can send a specially crafted request that crashes the node, causing a denial of service.
Read the original description
Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to denial of service via Serialized Data with Nested Payloads (CAPEC-230). An unauthenticated attacker with network access to the remote cluster server interface of a node can send a specially crafted request that causes the node to terminate. No credentials are required. The attacker can repeat the request against each reachable node.
What to do
Check whether your setup matches what the bug needs.
Elasticsearch nodes with the remote cluster server interface enabled Affected 8.x versions from 8.10.0 up to and including 8.19.23Upgrade to a fixed version: 8.19.24, 9.4.9, 9.5.6.
Workaround: Disable the remote cluster server interface if API key based remote cluster connections are not used, or use IP filtering to allow only trusted remote cluster addresses.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Elastic Elasticsearch
From 8.10.0 · through 8.19.23; From 9.0.0 · through 9.4.8; From 9.5.0 · through 9.5.5
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-115290
Is CVE-2026-115290 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A specially crafted request can make an Elasticsearch node terminate, which is a denial of service. The same request can be repeated against each reachable node.Source: discuss.elastic.co
Which versions are affected by CVE-2026-115290?
Elasticsearch: from 8.10.0 through 8.19.23; from 9.0.0 through 9.4.8; from 9.5.0 through 9.5.5.Source: cve.now feed data
Am I affected, and how do I check?
Affected versions are Elasticsearch 8.10.0 through 8.19.23, 9.0.0 through 9.4.8, and 9.5.0 through 9.5.5. The issue applies only to nodes with the remote cluster server interface enabled, so check the version each node runs and whether that interface is enabled in its configuration.Source: discuss.elastic.co
How do I fix CVE-2026-115290?
Upgrade to 8.19.24 on the 8.19 line, 9.4.9 on the 9.4 line, or 9.5.6 on the 9.5 line. The advisory states the issue is resolved in these versions.Source: discuss.elastic.co