Skip to main content
← All vulnerabilities
CVE-2026-114716

Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a mail header injection vulnerability.

Affects Roundcube Webmail 1.6.0 through 1.6.19 and 1.7.0 through 1.7.4. Fixed in 1.6.20 and 1.7.5.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 1.6.20, 1.7.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a mail header injection vulnerability. rcmail_sendmail::extract_inline_images() used the media type taken from an inline image data URI without validating it, so a remote authenticated attacker could inject arbitrary MIME part headers into the outgoing message by placing CRLF sequences in that media type. Upstream fixed this in the commit “Fix mail header injection via media type in an inline image data URI”, which validates the media type with rcube_mime::is_mimetype_valid().

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Roundcube Webmail

    From 1.6.0 · fixed in 1.6.20; From 1.7.0 · fixed in 1.7.5

References 6

bugs.debian.org

GitHub · roundcube/roundcubemail

roundcube.net

FAQ

Questions about CVE-2026-114716

What does this mean?

A crafted media type in an inline image data URI can inject extra mail headers into outgoing messages sent by Roundcube Webmail. This lets the injected content alter how the message is built and delivered.Source: roundcube.net

Am I affected, and how do I check?

Roundcube Webmail 1.6 LTS releases before 1.6.20 and 1.7 releases before 1.7.5 are in scope. To check a installation, look at the version shown in the Roundcube About page or in the package version on the server.Source: roundcube.net

What should I do about it?

Upgrade to Roundcube Webmail 1.6.20 if you run the 1.6 LTS line, or to 1.7.5 if you run the 1.7 line. The security updates 1.6.20 and 1.7.5 contain the fix.Source: roundcube.net

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data