GutenKit 2.5.0 - 2.5.4 - Author+ Stored XSS via Page Settings Custom CSS
- Exploited
- No known exploitation
- Fix
- Fixed in 2.5.5
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.5.5.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.16% · 5th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 11/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The GutenKit WordPress plugin has a stored cross-site scripting flaw: users with the Author role or higher can save custom page CSS that breaks out of its style block and runs JavaScript in the browser of any visitor who views the post.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
The GutenKit WordPress plugin before 2.5.5 does not properly sanitize custom CSS saved against a post before printing it inside an inline style block on the published page, allowing users with the Author role and above to break out of the style element and store JavaScript that executes in the browser of any visitor who views the post. Exploitation affects sites running WordPress below 7.0.
cve.now Index
- Exploitation0/40No signal
- Exposure3/25Reachable over the network · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.8/10CVSS 6.8, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 2.5.5.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Unknown GutenKit
From 2.5.0 · fixed in 2.5.5
Evidence 1
- Exploit
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-114427
Is CVE-2026-114427 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-114427?
GutenKit: from 2.5.0 before 2.5.5.Source: cve.now feed data
How do I fix CVE-2026-114427?
Upgrade to a fixed version: 2.5.5.Source: cve.now feed data