Skip to main content
← All vulnerabilities
CVE-2026-114422EUVD-2026-113743GHSA-57RW-QX68-P67C

Enable Media Replace 4.1.4 - 4.2.2 - Unauthenticated PHP Object Injection via Metadata Replacer

Affects Enable Media Replace versions 4.1.4 through 4.2.2. The fix is in 4.2.3.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 4.2.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The Enable Media Replace plugin for WordPress is affected. An unauthenticated attacker could inject a malicious PHP object that gets run when a user with upload permissions performs a media replacement, potentially allowing local file inclusion of existing PHP or HTML files and, in some conditions, remote code execution on the website's server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Unknown Enable Media Replace

    From 4.1.4 · fixed in 4.2.3

References 1

wpscan.com

FAQ

Questions about CVE-2026-114422

What does this mean?

The bug allows PHP Object Injection and local file inclusion of existing PHP or HTML files on the server. Where an attacker-influenced PHP or HTML file is present, this can be escalated to remote code execution.Source: wpscan.com

Am I affected, and how do I check?

Enable Media Replace versions 4.1.4 through 4.2.2 are affected. To check a site's version, look at the installed plugin version in the plugin list of the site's admin area.Source: wpscan.com

What should I do about it?

Upgrade Enable Media Replace to version 4.2.3, which contains the fix.Source: wpscan.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data