Black: GitHub Action installs unvalidated required-version from pyproject.toml
Affects Black's GitHub Action when use_pyproject is set to true, in Black 26.9.0 and 26.10.0. Fixed in 26.10.1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 26.10.1
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Victim uses Black's GitHub Action with use_pyproject: true Affected Black versions are 26.9.0 and 26.10.0
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 37/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Black, the Python code formatter, has a flaw in its GitHub Action (when use_pyproject is set to true) that lets an attacker who can submit a pull request run their own code in the GitHub Actions context of the victim repository. The attack is carried out remotely, and it requires only low-privilege login rather than no login at all.
Read the original description
Black is the uncompromising Python code formatter. Prior to 26.10.1, the Black GitHub Action with use_pyproject: true accepts tool.black.required-version from pyproject.toml without validating that it is a released Black version specifier. An attacker who can submit a pull request can change that field to a direct reference to attacker-controlled code, causing the workflow to install and execute the code in the victim repository's GitHub Actions context. This issue is fixed in version 26.10.1.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach20/20black: 27.9M downloads a week
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 87 if added to CISA KEV
- Would score about 82 if CISA's SSVC rates exploitation active
- Would score about 44 if CISA's SSVC rates it automatable
Impact
- Widely used
black has 27.9m weekly downloads.Source: pypistats.org
2.6k packages depend on black.Source: deps.dev
What to do
Check whether your setup matches what the bug needs.
Victim uses Black's GitHub Action with use_pyproject: true Affected Black versions are 26.9.0 and 26.10.0Upgrade to a fixed version: 26.10.1.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- psf black
fixed in 26.10.1
- blackPyPI
fixed in 26.10.1
Evidence 3
- Advisory
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-114134
Is CVE-2026-114134 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The Black GitHub Action installs a required-version taken from pyproject.toml without validating it. The advisory describes this as remote code execution, where untrusted code can run in the context of the repository.Source: github.com
Which versions are affected by CVE-2026-114134?
black: before 26.10.1. black (PyPI): before 26.10.1.Source: cve.now feed data
Am I affected, and how do I check?
The bug is in the GitHub Action bundled with psf/black when use_pyproject is set to true, in Black versions 26.9.0 and 26.10.0. To check a setup, look at the use_pyproject input in the workflow file that uses the Black action, and check the Black version the action installs.Source: github.com
How do I fix CVE-2026-114134?
Upgrade to Black 26.10.1, which is the listed fixed version.Source: github.com