Skip to main content
← Vulnerabilities

IBM MQ is affected by a denial of service vulnerability

Affects IBM MQ 9.2.0.0-9.2.0.44 LTS, 9.3.0.0-9.3.0.42 LTS, 9.4.0.0-9.4.0.26 LTS, 9.4.0.0-9.4.5.1 CD and 10.0.0.0-10.0.0.5 LTS/CD with the MQ Server component. The listed fix is cumulative security update 9.2.0.46.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 9.2.0.46
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affects IBM MQ 9.2.0.0 to 9.2.0.44 LTS, 9.3.0.0 to 9.3.0.42 LTS, 9.4.0.0 to 9.4.0.26 LTS, 9.4.0.0 to 9.4.5.1 CD, and 10.0.0.0 to 10.0.0.5 LTS and CD Affects the MQ Server installable component

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.8/10CVSS 8.8
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-11376 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects MQ; fixed in 9.2.0.46.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in 9.2.0.46
None on Exploit-DB, Metasploit or GitHub

Summary

IBM MQ is affected by a denial of service vulnerability caused by an integer overflow when it processes subscription requests with crafted buffer size values. An attacker who can log in with low-privilege credentials can reach it remotely over the network and can crash the service or potentially execute arbitrary code.

Read the original description

IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to cause a denial of service or potentially execute arbitrary code due to an integer overflow when processing subscription requests with crafted buffer size values.

What to do

  • Check whether your setup matches what the bug needs.

    Affects IBM MQ 9.2.0.0 to 9.2.0.44 LTS, 9.3.0.0 to 9.3.0.42 LTS, 9.4.0.0 to 9.4.0.26 LTS, 9.4.0.0 to 9.4.5.1 CD, and 10.0.0.0 to 10.0.0.5 LTS and CD Affects the MQ Server installable component
  • Upgrade to a fixed version: 9.2.0.46.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM MQ

    From 9.2.0.0 · through 9.2.0.44; From 9.3.0.0 · through 9.3.0.42; From 9.4.0.0 · through 9.4.0.26; From 9.4.0.0 · through 9.4.5.1; From 10.0.0.0 · through 10.0.0.5

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-11376

Is CVE-2026-11376 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A flaw in how MQ processes subscription requests with crafted buffer size values causes an integer overflow. An authenticated attacker could use it to cause a denial of service, and the advisory says it could potentially lead to arbitrary code execution.Source: ibm.com

Which versions are affected by CVE-2026-11376?

MQ: from 9.2.0.0 through 9.2.0.44; from 9.3.0.0 through 9.3.0.42; from 9.4.0.0 through 9.4.0.26; from 9.4.0.0 through 9.4.5.1; from 10.0.0.0 through 10.0.0.5.Source: cve.now feed data

Am I affected, and how do I check?

The advisory lists IBM MQ 9.2.0.0 to 9.2.0.44 LTS, 9.3.0.0 to 9.3.0.42 LTS, 9.4.0.0 to 9.4.0.26 LTS, 9.4.0.0 to 9.4.5.1 CD, and 10.0.0.0 to 10.0.0.5 LTS and CD. It applies to the MQ Server installable component. To check a version, run dspmqver on the MQ server and compare the reported version with these ranges.Source: ibm.com

How do I fix CVE-2026-11376?

Apply cumulative security update 9.2.0.46, which is the fix named in the advisory.Source: ibm.com