Docker Desktop WSL2 AF_VSOCK isolation bypass via 32-bit socketcall
Affects Docker Desktop with the WSL 2 backend, where a container could bypass the AF_VSOCK restriction. The fix requires WSL 3.0.3 or later.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in WSL 3.0.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Docker Desktop with the WSL 2 backend
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach17/20Affects Docker (a widely deployed server, runtime, framework or database)
- Severity9.2/10CVSS 9.2
- No patch0/5No signal
What would change the score
- Would score about 81 if added to CISA KEV
- Would score about 76 if CISA's SSVC rates exploitation active
- Would score about 41 if CISA's SSVC rates it automatable
CVE-2026-112917 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.2 (critical) and affects Docker Desktop; fixed in WSL 3.0.3.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 31/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in WSL 3.0.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Docker Desktop for Windows using the WSL2 backend on x86-64 systems is affected, allowing an unprivileged Linux container to bypass its seccomp restriction on AF_VSOCK sockets. This could let the container reach host-facing services and access Windows files available to the logged-in user, and full protection requires both a newer Docker Desktop and a newer WSL version.
Read the original description
In Docker Desktop for Windows with the WSL2 backend, an unprivileged Linux container can use 32-bit socketcall to bypass the default seccomp restriction on AF_VSOCK. This can expose host-facing services and Windows files accessible to the logged-in user. The issue affects x86-64 WSL2; LinuxKit-based backends are unaffected. The issue is fully fixed only with Docker Desktop 4.98.0 or later and WSL 3.0.3 or later. Docker Desktop 4.98.0 or later running on an older WSL remains affected.
What to do
Check whether your setup matches what the bug needs.
Docker Desktop with the WSL 2 backendUpgrade to a fixed version: WSL 3.0.3.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- Docker Docker Desktop
Version range not reported
Evidence 3
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-112917
Is CVE-2026-112917 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A container running on the WSL 2 backend of Docker Desktop could get past the AF_VSOCK restriction that is meant to limit it.Source: docs.docker.com
Am I affected, and how do I check?
The affected setup is Docker Desktop using the WSL 2 backend. The facts do not list specific affected Docker Desktop versions, so check whether your Docker Desktop uses the WSL 2 backend in its settings.Source: docs.docker.com
How do I fix CVE-2026-112917?
Update WSL to version 3.0.3 or later, which the fix requires.Source: docs.docker.com