Skip to main content
← Vulnerabilities

Pillow: EPS load(scale) lets Ghostscript render past the decompression bomb limit

6.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 13.0.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 13.0.0.

Published
Last modified
23/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

Pillow, a Python imaging library, can be made to use excessive CPU and temporary disk space when it processes an untrusted EPS or PostScript file with an application-selected scale greater than one. This can be triggered remotely, without logging in, and the bug is fixed in a newer release.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Pillow is a Python imaging library. In versions 2.3.0 through 12.3.0, EPS rendering does not validate the scaled image dimensions before invoking Ghostscript. Applications that process untrusted EPS or PostScript files using an application-selected scale greater than one can incur excessive Ghostscript CPU and temporary disk consumption. In versions with decompression-bomb protection, the scaled output is checked only after Ghostscript has completed rendering, allowing resource consumption beyond the configured pixel limit. The amplification depends on the scale selected by the application, not an attacker-controlled scale value. This issue is fixed in version 13.0.0.

cve.now Index

23Pcve.now Index 23 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity6.3/10CVSS 6.3
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 28 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 13.0.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • python-pillow Pillow

    From 2.5.0 · fixed in 13.0.0

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-112899

Is CVE-2026-112899 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-112899?

Pillow: from 2.5.0 before 13.0.0.Source: cve.now feed data

How do I fix CVE-2026-112899?

Upgrade to a fixed version: 13.0.0.Source: cve.now feed data