Improper certificate validation in the HTTPS listener in LXD
LXD 4.0.14 to 4.0.15, 5.0.10 to 5.0.11, 5.21.8 to 5.21.9, and 6.9.0 to 6.10.1 are affected, with fixes in the listed upper versions. Vendor severity is not given; CVSS scores it 10 (critical).
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 4.0.15, 5.0.11, 5.21.9, 6.10.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
Canonical LXD, a system container and virtual machine manager, is affected by this vulnerability. An unauthenticated attacker could exploit flaws in certificate validation on its HTTPS listener to impersonate a trusted client, gaining full control over the cluster and the virtual machines it manages.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
Timeline
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- Record last updated
Affected versions
- lxd
From 4.0.14 · fixed in 4.0.15; From 5.0.10 · fixed in 5.0.11; From 5.21.8 · fixed in 5.21.9; From 6.9.0 · fixed in 6.10.1
References 6
GitHub · canonical/lxd
Questions about CVE-2026-112816
What does this mean?
The LXD HTTPS listener does not properly validate TLS client certificates. An attacker who can reach the LXD HTTPS API and holds the public certificate of a trusted TLS client can authenticate as that client. Depending on the victim's privilege, this can lead to root access on the host. In MicroCloud, an attacker can also intercept the public TLS certificate of a joining cluster member.Source: discourse.ubuntu.com
Am I affected, and how do I check?
The affected ranges are LXD 4.0.14 up to 4.0.15, 5.0.10 up to 5.0.11, 5.21.8 up to 5.21.9, and 6.9.0 up to 6.10.1. To check a installation, run the lxd --version command and compare the result against these ranges. MicroCloud setups that use LXD are also in scope.Source: discourse.ubuntu.com
What should I do about it?
Upgrade to the fixed release for the branch in use: 4.0.15, 5.0.11, 5.21.9, or 6.10.1.Source: discourse.ubuntu.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data