Skip to main content
← Vulnerabilities

vault-java-driver: stored deeply nested JSON kills every thread that reads it

6.5MediumCNA
Exploited
No known exploitation
Fix
Fixed in 7.0.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 7.0.0.

Published
Last modified
0.33% · 25th percentile
20/100 · provisional
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The vault-java-driver Java client for HashiCorp Vault can be attacked over the network by a user with low privileges who stores a deeply nested JSON value on a KV v2 path they can write but not read, which crashes any thread that later reads that path. The attack works only against older Vault servers that accept such deeply nested values.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

vault-java-driver, a Java client for HashiCorp Vault, parses Vault's JSON responses with a vendored minimal-json parser that has no nesting depth limit. A deeply nested value raises a StackOverflowError, which escapes catch (Exception) handlers and kills the reading thread. A Vault token that can write but not read a KV v2 path can store such a value there, so every later read of that path through the driver fails. This requires Vault 1.19.x or earlier, because 1.20 and later reject values nested deeper than 298 levels. This issue affects io.github.jopenlibs:vault-java-driver 5.2.0 through 6.2.3 and is fixed in 7.0.0.

cve.now Index

20Pcve.now Index 20 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure3/25Reachable over the network · Unknown: No advisory context yet
  • Reach10/20Affects Maven packages
  • Severity6.5/10CVSS 6.5
  • No patch0/5No signal

What would change the score

  • Would score about 75 if added to CISA KEV
  • Would score about 70 if CISA's SSVC rates exploitation active
  • Would score about 39 if advisories confirm default setups are exposed

Impact

  • Widely used

    8 packages depend on io.github.jopenlibs:vault-java-driver.Source: deps.dev

What to do

  • Upgrade to a fixed version: 7.0.0.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • io.github.jopenlibs:vault-java-driverMaven

    From 5.2.0 · fixed in 7.0.0

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-112072

Is CVE-2026-112072 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-112072?

io.github.jopenlibs:vault-java-driver (Maven): from 5.2.0 before 7.0.0.Source: cve.now feed data

How do I fix CVE-2026-112072?

Upgrade to a fixed version: 7.0.0.Source: cve.now feed data