Skip to main content
← Vulnerabilities

Apache ActiveMQ, Apache ActiveMQ KahaDB: Oversized client identifier strings poison the KahaDB journal

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
Fixed in 6.3.3, 5.19.12
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 6.3.3, 5.19.12.

10Pcve.now Index 10 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure?/25Exposure: unknown (data gap). No advisory context yet
  • Reach10/20Affects Maven packages
  • Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 32 if advisories confirm default setups are exposed

CVE-2026-111821 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Apache ActiveMQ and Apache ActiveMQ KahaDB; fixed in 6.3.3 and 5.19.12.

Published
Last modified
Published
Not listed in CISA KEV
10/100 · provisional
Fix
Fixed in 6.3.3, 5.19.12
None on Exploit-DB, Metasploit or GitHub

Summary

Apache ActiveMQ and its KahaDB persistence component are affected. An authenticated user who can create a durable subscription can send an oversized client ID and subscription name, which can crash the broker and leave it unable to recover.

Read the original description

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.  This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

Impact

  • Widely used

    4 packages depend on org.apache.activemq:apache-activemq.Source: deps.dev

What to do

  • Upgrade to a fixed version: 6.3.3, 5.19.12.

Timeline

  1. CVE published
  2. Record last updated
  3. First seen by cve.now

Affected versions

  • org.apache.activemq:apache-activemqMaven

    From 6.0.0 · fixed in 6.3.3; fixed in 5.19.12

  • org.apache.activemq:activemq-kahadb-storeMaven

    From 6.0.0 · fixed in 6.3.3; fixed in 5.19.12

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-111821

Is CVE-2026-111821 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-111821?

org.apache.activemq:apache-activemq (Maven): from 6.0.0 before 6.3.3; before 5.19.12. org.apache.activemq:activemq-kahadb-store (Maven): from 6.0.0 before 6.3.3; before 5.19.12.Source: cve.now feed data

How do I fix CVE-2026-111821?

Upgrade to a fixed version: 6.3.3, 5.19.12.Source: cve.now feed data