Path traversal in plug-in deployment
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2026.6
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. PLCnext Engineer versions prior to 2026.6 A crafted plugin package containing relative path segments is deployed
- Exploitation0/40No signal
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.6/10CVSS 8.6, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 25 if CISA's SSVC rates it automatable
CVE-2026-110935 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects PLCnext Engineer; fixed in 2026.6.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.20% · 9th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2026.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The PFI plugin framework's deployment routine fails to reject parent-directory segments (such as "..") when extracting plugin archives, so a local attacker who needs no login can write files to arbitrary locations the current user can access, potentially leading to full system compromise. This is a local attack that requires no user action.
Read the original description
The PFI plugin framework deployment routine does not validate path components when extracting archive entries to the local plugin repository. Archive entries containing relative path segments such as '..' are not rejected, allowing an unauthenticated local attacker to write files outside the plugin repository to arbitrary locations accessible with the current user's permissions which could result in full system compromise.
What to do
Check whether your setup matches what the bug needs.
PLCnext Engineer versions prior to 2026.6 A crafted plugin package containing relative path segments is deployedUpgrade to a fixed version: 2026.6.
Workaround: Install plugins only from trusted sources and verified engineering libraries.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Phoenix Contact PLCnext Engineer
From 0.0 · fixed in 2026.6
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-110935
Is CVE-2026-110935 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A crafted plugin package containing relative path segments can make PLCnext Engineer write files outside the plugin repository. The written files can land in any location the current user is allowed to write to.Source: certvde.com
Which versions are affected by CVE-2026-110935?
PLCnext Engineer: from 0.0 before 2026.6.Source: cve.now feed data
Am I affected, and how do I check?
Versions of PLCnext Engineer prior to 2026.6 are affected, and the issue arises when a crafted plugin package with relative path segments is deployed. To check, look at the PLCnext Engineer version in the product's about or version information and see whether it is earlier than 2026.6.Source: certvde.com
How do I fix CVE-2026-110935?
Upgrade to PLCnext Engineer 2026.6, which the vendor states fixes these vulnerabilities. Until then, install plugins only from trusted sources and verified engineering libraries.Source: certvde.com