Essential Addons for Elementor 6.6.0 - 6.8.7 - Author+ Privilege Escalation via register_user_role
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 6.8.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Essential Addons for Elementor plugin for WordPress is affected, specifically its user registration feature. An attacker with Author-level access or higher can cause new accounts, including those signed up by unauthenticated visitors, to be assigned a higher role such as Editor, which can lead to unauthorized privilege escalation.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The Essential Addons for Elementor WordPress plugin before 6.8.8 does not correctly restrict who may set the role assigned to accounts created through its registration form, allowing authenticated users with Author-level access and above to cause newly registered accounts, including those created by unauthenticated visitors through the public registration form, to be granted a higher role such as Editor. This is an incomplete fix of CVE-2026-5193: the role-validation control added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even on sites that are patched against that advisory.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Unknown Essential Addons for Elementor
From 6.6.0 · fixed in 6.8.8
References 1
Questions about CVE-2026-110808
What does this mean?
Newly registered accounts can be given a higher role, such as Editor, than the site intended. The flaw is in how the registration form assigns roles to new users, and it can be reached by unauthenticated visitors.Source: wpscan.com
Am I affected, and how do I check?
Essential Addons for Elementor versions 6.6.0 through 6.8.7 are affected, but only on sites that use the plugin's registration form to create accounts with an assigned role. To check, look at the plugin version under Plugins in the WordPress admin and see whether the registration form feature is enabled in the plugin's settings.Source: wpscan.com
What should I do about it?
Update Essential Addons for Elementor to version 6.8.8 or later, which contains the fix.Source: wpscan.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data