Altair: DOM-based XSS via attacker-controlled script URLs in the iframe sandbox
- Exploited
- No known exploitation
- Fix
- Fixed in 8.5.8
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 8.5.8.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Altair, a GraphQL client, has a DOM-based cross-site scripting flaw in its iframe sandbox that lets an attacker run script in the origin serving Altair. The attacker can reach it remotely, without logging in, by getting a victim to open a crafted link, and the script can then read script-accessible storage and make same-origin requests.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Altair is a GraphQL client for all platforms. From 7.2.4 until 8.5.8, packages/altair-iframe-sandbox/src/main.ts reads plugin_sandbox_opts from the iframe-sandbox query string and passes attacker-controlled scriptUrls to injectScript() in packages/altair-core/src/utils/inject.ts, which creates script elements in the page. The intended parent iframe flow places the page in an iframe with sandbox allow-scripts and without allow-same-origin, but direct navigation to a crafted iframe-sandbox URL omits that isolation and executes the supplied script in the origin serving Altair. Exploitation requires a victim to open the crafted URL, and the resulting script can access script-readable storage and make same-origin requests according to the deployment's authentication and cookie controls. This issue is fixed in version 8.5.8.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure7/25Reachable over the network without a login · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity6.1/10CVSS 6.1
- No patch0/5No signal
What would change the score
- Would score about 68 if added to CISA KEV
- Would score about 63 if CISA's SSVC rates exploitation active
- Would score about 28 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 8.5.8.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- altair-graphql altair
From 7.2.4 · fixed in 8.5.8
- altair-graphql altair-express-middleware
From 7.2.4 · fixed in 8.5.8
- altair-graphql altair-fastify-plugin
From 7.2.4 · fixed in 8.5.8
- altair-graphql altair-koa-middleware
From 7.2.4 · fixed in 8.5.8
- altair-graphql altair-static
From 7.2.4 · fixed in 8.5.8
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-110802
Is CVE-2026-110802 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-110802?
altair: from 7.2.4 before 8.5.8. altair-express-middleware: from 7.2.4 before 8.5.8. altair-fastify-plugin: from 7.2.4 before 8.5.8. altair-koa-middleware: from 7.2.4 before 8.5.8. altair-static: from 7.2.4 before 8.5.8.Source: cve.now feed data
How do I fix CVE-2026-110802?
Upgrade to a fixed version: 8.5.8.Source: cve.now feed data