Skip to main content
← All vulnerabilities
CVE-2026-110309EUVD-2026-113126GHSA-CWVV-W2H8-Q5P2

Langflow OSS is affected by multiple vulnerabilities

Affects IBM Langflow OSS versions 1.0.0 through 1.12.4. IBM recommends upgrading to version 1.12.5, which fixes the vulnerability.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 1.12.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to execute arbitrary commands due to improper control of code generation.

Timeline

  1. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  2. CVE published
  3. First seen by cve.now
  4. Record last updated

Affected versions

  • IBM Langflow OSS

    From 1.0.0 · through 1.12.4

References 1

ibm.com

FAQ

Questions about CVE-2026-110309

What does this mean?

Multiple flaws in Langflow OSS could let a remote user who is already authenticated run arbitrary commands on the system. The impact is to the host the software runs on.Source: ibm.com

Am I affected, and how do I check?

Langflow OSS versions 1.0.0 through 1.12.4 are in the affected range. To check, compare the installed Langflow OSS version against that range.Source: ibm.com

What should I do about it?

Upgrade Langflow OSS to version 1.12.5. IBM strongly recommends addressing the vulnerability now by upgrading to that version.Source: ibm.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data