Langflow OSS is affected by multiple vulnerabilities
Langflow OSS 1.0.0 through 1.12.8 is affected when the attacker holds a low-privileged authenticated account. The fix is in 1.13.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.13.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
IBM Langflow OSS, an open-source platform for building AI workflows, is affected by this vulnerability. A remote attacker with a low-privileged authenticated account could manipulate the Agentic Assistant into generating or submitting component code that executes arbitrary operating system commands on the server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.
Timeline
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- CVE published
- First seen by cve.now
- Record last updated
Affected versions
- IBM Langflow OSS
From 1.0.0 · through 1.12.8
References 1
ibm.com
Questions about CVE-2026-110193
What does this mean?
The bug lets the Agentic Assistant generate or submit component code using patterns that are not blocked. That code can run arbitrary operating system commands on the server.Source: ibm.com
Am I affected, and how do I check?
Langflow OSS versions 1.0.0 through 1.12.8 are in the affected range. Check the installed Langflow OSS version against that range, and note that the issue concerns the Agentic Assistant.Source: ibm.com
What should I do about it?
Upgrade Langflow OSS to version 1.13.0, which the vendor's fix guidance names for installations running 1.0.0 through 1.12.8.Source: ibm.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data