Signed plug-in validation bypass
PLCnext Engineer versions before 2026.6 that use the PFI plugin framework are affected. Upgrade to 2026.6, which fixes the issue.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2026.6
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. PLCnext Engineer prior to version 2026.6 with the PFI plugin framework
- Exploitation0/40No signal
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.6/10CVSS 8.6, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 25 if CISA's SSVC rates it automatable
CVE-2026-110022 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects PLCnext Engineer; fixed in 2026.6.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.11% · 1st percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2026.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The PFI plugin framework deploys executable assemblies (DLLs) from a signed plugin package into the local plugin repository and loads them via reflection, but the deployment routine processes archive entries that were never covered by the signature verification. An unauthenticated local attacker can replace an unsigned DLL outside the signed prefix in the archive passes verification and overwrites the legitimate signed assembly at the same destination path. The plugin loader then instantiates the attacker-supplied code without any additional integrity check resulting in a full compromise of the affected systems.
What to do
Check whether your setup matches what the bug needs.
PLCnext Engineer prior to version 2026.6 with the PFI plugin frameworkUpgrade to a fixed version: 2026.6.
Workaround: Install plugins only from trusted sources and verified engineering libraries
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Phoenix Contact PLCnext Engineer
From 0.0 · fixed in 2026.6
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-110022
Is CVE-2026-110022 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The flaw lets arbitrary code run in the context of the PLCnext Engineer user, which can lead to full compromise of the affected system.Source: certvde.com
Which versions are affected by CVE-2026-110022?
PLCnext Engineer: from 0.0 before 2026.6.Source: cve.now feed data
Am I affected, and how do I check?
PLCnext Engineer versions prior to 2026.6 that use the PFI plugin framework are in scope. Compare the installed PLCnext Engineer version number with 2026.6 to see which side of the fix a given install falls on.Source: certvde.com
How do I fix CVE-2026-110022?
Upgrade to PLCnext Engineer 2026.6, which Phoenix Contact strongly recommends as the fix. Until the upgrade is done, install plugins only from trusted sources and verified engineering libraries.Source: certvde.com