Skip to main content
← Vulnerabilities

APT RCE via hard link reuse

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.2.36, 1.4.12, 1.6.19, 1.8.2.4, 2.0.12, and 10 more
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 1.2.36, 1.4.12, 1.6.19, 1.8.2.4, 2.0.12, or one of 10 more.

31Pcve.now Index 31 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach10/20Shipped in major Linux distributions
  • Severity8.7/10CVSS 7.7, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 81 if added to CISA KEV
  • Would score about 76 if CISA's SSVC rates exploitation active

CVE-2026-109518 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.7 (high) and affects APT; fixed in 1.2.36, 1.4.12, 1.6.19 and 12 more.

Published
Last modified
Published
Not listed in CISA KEV
31/100 · provisional
Specific setups only
Fix
Fixed in 1.2.36, 1.4.12, 1.6.19, 1.8.2.4, 2.0.12, and 10 more
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

APT, the package manager on Debian, Ubuntu, and their derivatives, can be tricked into installing an attacker-controlled, unverified package, giving the attacker remote code execution with root privileges. An attacker on the network path, such as through a malicious mirror or proxy that manipulates HTTP traffic, can reach it remotely without logging in, but it requires a user to run a package install and the client to have download retries enabled.

Read the original description

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges. The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

What to do

  • Upgrade to a fixed version: 1.2.36, 1.4.12, 1.6.19, 1.8.2.4, 2.0.12, or one of 10 more.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

    1 day
  4. Record last updated

Affected versions

  • apt

    fixed in 1.2.36; From 1.4.0 · fixed in 1.4.12; From 1.6.0 · fixed in 1.6.19; From 1.8.0 · fixed in 1.8.2.4; From 1.8.3 · through 1.8.5; From 2.0.0 · fixed in 2.0.12; From 2.2.0 · fixed in 2.2.5; From 2.4.0 · fixed in 2.4.15; From 2.6.0 · fixed in 2.6.2; From 2.8.0 · fixed in 2.8.4; From 3.0.0 · fixed in 3.0.4; From 3.2.0 · fixed in 3.2.1; From 3.3.0 · fixed in 3.3.6

  • apt

    fixed in 1.0.1ubuntu2.24+esm4; From 1.2.0 · fixed in 1.2.36+esm1; From 1.6.0 · fixed in 1.6.19+esm1; From 2.0.0 · fixed in 2.0.12+esm1; From 2.4.0 · fixed in 2.4.15ubuntu0.1; From 2.8.0 · fixed in 2.8.4ubuntu0.1; From 3.2.0 · fixed in 3.2.1ubuntu0.1; From 3.3.0 · fixed in 3.3.3ubuntu0.1

Evidence 5

  1. Advisory
  2. Advisory
  3. Exploit
  4. Link
  5. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-109518

Is CVE-2026-109518 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A man-in-the-middle attacker who sits between APT and its package source can replace a package after APT has verified it. The replaced package then runs arbitrary code with root privileges.Source: lists.debian.org

Which versions are affected by CVE-2026-109518?

apt: before 1.2.36; from 1.4.0 before 1.4.12; from 1.6.0 before 1.6.19; from 1.8.0 before 1.8.2.4; from 1.8.3 through 1.8.5; from 2.0.0 before 2.0.12; from 2.2.0 before 2.2.5; from 2.4.0 before 2.4.15; from 2.6.0 before 2.6.2; from 2.8.0 before 2.8.4; from 3.0.0 before 3.0.4; from 3.2.0 before 3.2.1; from 3.3.0 before 3.3.6. apt: before 1.0.1ubuntu2.24+esm4; from 1.2.0 before 1.2.36+esm1; from 1.6.0 before 1.6.19+esm1; from 2.0.0 before 2.0.12+esm1; from 2.4.0 before 2.4.15ubuntu0.1; from 2.8.0 before 2.8.4ubuntu0.1; from 3.2.0 before 3.2.1ubuntu0.1; from 3.3.0 before 3.3.3ubuntu0.1.Source: cve.now feed data

Am I affected, and how do I check?

The advisory lists Debian APT and Ubuntu APT, each with version ranges that differ by release line. To check a system, run `apt --version` and compare the result against the fixed versions for its distribution.Source: lists.debian.org

How do I fix CVE-2026-109518?

Upgrade APT to the fixed version for your distribution. For Debian stable (trixie), that is 3.0.4.Source: lists.debian.org