Buffer Overflow in Digital I/O
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.5.116, 1.0.124, 1.0.123
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure3/25Reachable over the network · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity6.9/10CVSS 6.9
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 29 if advisories confirm default setups are exposed
CVE-2026-109161 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.9 (medium) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.30% · 22nd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 10/100 · provisional
- Fix
- Fixed in 3.5.116, 1.0.124, 1.0.123
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Digital I/O function in affected software does not adequately check data boundaries, which can be abused by a remote attacker who already has high-level privileges. Successful exploitation could cause the software to crash or stop responding, resulting in a denial of service.
Read the original description
Insufficient bounds checking in the Digital I/O function may allow a remote attacker with high privileges to cause a denial of service.
What to do
Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Welotec TK100
From 0.0.0 · fixed in 3.5.116
- Welotec TK500-v2
From 0.0.0 · fixed in 1.0.124
- Welotec TK500-v3
From 0.0.0 · fixed in 1.0.123
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-109161
Is CVE-2026-109161 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-109161?
TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.Source: cve.now feed data
How do I fix CVE-2026-109161?
Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.Source: cve.now feed data