Apache Syncope: Remote Code Execution via Flowable JUEL expression
Affects Apache Syncope 3.0.0-M0 to 3.0.16, 4.0.0-M0 to 4.0.8 and 4.1.0 to 4.1.3 when a BPMN process with a JUEL expression is imported and started. Upgrade to 4.0.9 or 4.1.4.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.0.9, 4.1.4
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.0.9, 4.1.4.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.52% · 44th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 40/100
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
Apache Syncope, an open-source identity management system, is affected by this vulnerability. An administrator with sufficient privileges can import a malicious workflow definition and start it, allowing arbitrary code to run on the underlying server.
Read the original description
Improper isolation or compartmentalization vulnerability in Apache Syncope.
An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server, with no sandbox.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0 through 4.1.3.
Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue by rejecting BPMN definitions including expression attributes.
cve.now Index
- Exploitation0/40No signal
- Exposure20/25No login or user action needed, CISA rates it automatable · Unknown: Advisories don't say whether default setups are affected
- Reach10/20Affects Maven packages
- Severity10/10CVSS 9.8, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 85 if added to CISA KEV
- Would score about 80 if CISA's SSVC rates exploitation active
- Would score about 45 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 4.0.9, 4.1.4.
Timeline
- CVE published
- First seen by cve.now4 days
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
- Posted on X by cve.now
Affected versions
- org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmnMaven
From 3.0.0-M0 · through 3.0.16; From 4.0.0-M0 · through 4.0.8; From 4.1.0 · through 4.1.3
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-109083
Is CVE-2026-109083 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
When a BPMN process containing a JUEL expression is imported and started, Apache Syncope runs that expression directly on the server with no sandbox. This gives remote code execution on the server.Source: openwall.com
Which versions are affected by CVE-2026-109083?
org.apache.syncope.ext.flowable:syncope-ext-flowable-bpmn (Maven): from 3.0.0-M0 through 3.0.16; from 4.0.0-M0 through 4.0.8; from 4.1.0 through 4.1.3.Source: cve.now feed data
Am I affected, and how do I check?
Affected versions are Apache Syncope 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.8, and 4.1.0 through 4.1.3. Check the installed Syncope version against these ranges, and check whether BPMN processes containing JUEL expressions are imported and started on the installation.Source: openwall.com
How do I fix CVE-2026-109083?
The vendor recommends upgrading to version 4.0.9 or 4.1.4. No workaround is listed in the facts.Source: openwall.com