Skip to main content
← All vulnerabilities
CVE-2026-73668

Apache Syncope: Cross-realm disclosure of confidential ConnId bundles configuration values

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Incorrect Authorization vulnerability in Apache Syncope. An administrator with adequate entitlements in a given Realm may be able to read via REST the full Connector configuration, confidential properties included, scoped in another Realm and thus be able to effectively duplicate such Connector instance into the Realm they have administration rights for. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.syncope.core.idm:syncope-core-idm-logic

    From 3.0.0-M0 · through 3.0.16; From 4.0.0-M0 · through 4.0.7; From 4.1.0-M0 · through 4.1.2

References 1

lists.apache.org