Skip to main content
← Vulnerabilities

Apache ActiveMQ: LDAPAuthorizationMap allows authorization bypass via DN injection

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
Fixed in 6.3.3, 5.19.12
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 6.3.3, 5.19.12.

0Pcve.now Index 0 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure?/25Exposure: unknown (data gap). No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 55 if added to CISA KEV
  • Would score about 50 if CISA's SSVC rates exploitation active
  • Would score about 22 if advisories confirm default setups are exposed

CVE-2026-108500 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Apache ActiveMQ; fixed in 6.3.3 and 5.19.12.

Published
Last modified
Published
Not listed in CISA KEV
0/100 · provisional
Fix
Fixed in 6.3.3, 5.19.12
None on Exploit-DB, Metasploit or GitHub

Summary

Apache ActiveMQ servers configured with the LDAPAuthorizationMapPlugin let an authenticated user bypass authorization checks. The user creates or addresses a destination with a crafted name containing LDAP distinguished name special characters, such as commas, plus signs, equals signs, or backslashes, which alter the LDAP search base used for access control lookups.

Read the original description

Input validation vulnerability in Apache ActiveMQ configured to use the LDAPAuthorizationMapPlugin allows an authenticated attacker to create or address a destination with a crafted name containing LDAP DN special characters (such as comma, plus, equals, backslash) can manipulate the LDAP search base used for ACL lookups. This issue affects Apache ActiveMQ: from 6.3.0 before 6.3.3, from 5.19.0 before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

What to do

  • Upgrade to a fixed version: 6.3.3, 5.19.12.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • Apache Software Foundation Apache ActiveMQ

    From 6.3.0 · fixed in 6.3.3; From 5.19.0 · fixed in 5.19.12

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-108500

Is CVE-2026-108500 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-108500?

Apache ActiveMQ: from 6.3.0 before 6.3.3; from 5.19.0 before 5.19.12.Source: cve.now feed data

How do I fix CVE-2026-108500?

Upgrade to a fixed version: 6.3.3, 5.19.12.Source: cve.now feed data