Skip to main content
← All vulnerabilities
CVE-2026-107929

local interface connection reuse mixup

Only affects curl 8.9.0 through 8.22.0 when CURLOPT_INTERFACE or --interface uses an if!, host!, or ifhost! prefix. curl rates it Low against a CVSS score of 8.1. Fixed in 8.23.0.

Published
Last modified
published
Not listed in CISA KEV
Unclear
Low (curl)
Fix
Fixed in 8.14.3, 8.16.2, 8.20.2, 8.23.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

When `CURLOPT_INTERFACE` (or the command line tool's `--interface` option) is set with one of the documented prefixes (`if!`, `host!`, `ifhost!`), that binding is not part of the connection reuse key, so a later transfer asking for a different source can silently reuse an existing connection and go out from the earlier transfer's source address

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • curl curl

    From 8.22.0 · through 8.22.0; From 8.21.0 · through 8.21.0; From 8.20.0 · through 8.20.0; From 8.19.0 · through 8.19.0; From 8.18.0 · through 8.18.0; From 8.17.0 · through 8.17.0; From 8.16.0 · through 8.16.0; From 8.15.0 · through 8.15.0; From 8.14.1 · through 8.14.1; From 8.14.0 · through 8.14.0; From 8.13.0 · through 8.13.0; From 8.12.1 · through 8.12.1; From 8.12.0 · through 8.12.0; From 8.11.1 · through 8.11.1; From 8.11.0 · through 8.11.0; From 8.10.1 · through 8.10.1; From 8.10.0 · through 8.10.0; From 8.9.1 · through 8.9.1; From 8.9.0 · through 8.9.0

References 3

curl.se

hackerone.com

FAQ

Questions about CVE-2026-107929

What does this mean?

A later transfer can silently reuse an existing connection and send its traffic from the source address of the earlier transfer instead of the address it requested.Source: curl.se, curl.se

Am I affected, and how do I check?

Affected are curl and libcurl versions 8.9.0 through 8.22.0, including the point releases 8.9.1, 8.10.1, 8.11.1, 8.12.1, 8.14.1 and the other listed releases in that range. Run curl --version to see your version, then check whether your setup sets CURLOPT_INTERFACE or --interface with an if!, host! or ifhost! prefix.Source: curl.se, curl.se

What should I do about it?

Upgrade curl to 8.23.0, or to the backported releases 8.14.3, 8.16.2 or 8.20.2 if you stay on those branches. Until you upgrade, avoid CURLOPT_INTERFACE and --interface.Source: curl.se, curl.se

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

Why is it rated 8.1 High?

The CVSS score of 8.1 describes the worst case. curl rates the issue Low because it only occurs when the interface option uses one of the specific prefixes listed in the advisory.Source: curl.se, curl.se