Skip to main content
← Vulnerabilities

musl libc before 1.2.7, when an untrusted regular expression is used with regcomp, has multiple integer overflows, possibly leading to…

Only affects musl 0.5.0 through 1.2.6 in applications that pass untrusted regular expressions to regcomp. Fixed in 1.2.7.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.2.7
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.2.7.

Published
Last modified
25/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

musl libc, the C standard library used by some Linux distributions, is affected by multiple integer overflows when it processes an untrusted regular expression passed to regcomp. An attacker who can supply such a pattern remotely, without logging in, could trigger incorrect memory allocation sizes and out-of-bounds heap writes, which could lead to code execution or crashes.

Read the original description

musl libc before 1.2.7, when an untrusted regular expression is used with regcomp, has multiple integer overflows, possibly leading to incorrect allocation sizes and out-of-bounds heap writes.

cve.now Index

25Pcve.now Index 25 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.1/10CVSS 8.1
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active
  • Would score about 30 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 1.2.7.

  • Workaround: Prevent the processing of regular expressions from untrusted sources.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • musl -libc musl

    From 0.5.0 · fixed in 1.2.7

Evidence 4

  1. Link
  2. Link
  3. Link
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-107891

Is CVE-2026-107891 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Several integer overflows in musl's regcomp can be triggered by a crafted regular expression. The result is at least a denial-of-service crash that is predictable, and depending on the application and its heap use, arbitrary code execution may be possible.Source: openwall.com

Which versions are affected by CVE-2026-107891?

musl: from 0.5.0 before 1.2.7.Source: cve.now feed data

Am I affected, and how do I check?

Versions of musl from 0.5.0 through 1.2.6 are affected, and the bug needs an application that processes regular expressions from an untrusted source with the libc regcomp function. To check, look at the musl version installed on the system, and review whether the application passes user-supplied patterns to regcomp.Source: openwall.com

How do I fix CVE-2026-107891?

Upgrade musl to version 1.2.7, which contains the fix. Until the upgrade is applied, prevent the processing of regular expressions from untrusted sources.Source: openwall.com