Nginx UI: Authenticated Remote Code Execution via Backup Restore App Config Overwrite
Only affects nginx-ui 2.3.8 up to 2.5.0 where an authenticated administrator can restore a crafted backup. Fixed in 2.5.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.5.0, 1.9.10-0.20260728074146-a467ed652591
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: total
Summary
Nginx UI, a web-based management interface for the Nginx web server, is affected. An administrator with an authenticated session can abuse the backup restore feature to overwrite the application's configuration and run arbitrary commands, compromising the confidentiality, integrity, and availability of the system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Nginx UI is a web user interface for the Nginx web server. From 2.3.8 until 2.5.0, an authenticated administrator with an active secure session can submit attacker-controlled portable backup key material and a matching manifest to POST /api/restore. The restore flow trusts the supplied key, decrypts attacker-controlled contents, and replaces the live app.ini, including protected nginx command settings such as TestConfigCmd. Triggering POST /api/nginx/test then executes the restored command in the Nginx UI runtime context, affecting confidentiality, integrity, and availability. This issue is fixed in version 2.5.0.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- 0xJacky nginx-ui
From 2.3.8 · fixed in 2.5.0
- github.com/0xJacky/Nginx-UIGo
From 1.9.10-0.20260421071512-7864e378f5cf · fixed in 1.9.10-0.20260728074146-a467ed652591
References 3
GitHub · 0xJacky/nginx-ui
Questions about CVE-2026-107806
What does this mean?
A logged-in nginx-ui administrator who restores a backup can overwrite the app.ini config with nginx command fields. Those commands then run inside the nginx-ui runtime, letting the attacker run commands there.Source: github.com, github.com
Am I affected, and how do I check?
Versions from 2.3.8 up to but not including 2.5.0 are affected, and the attacker must already hold an administrator account with an active secure session. To check, look at the nginx-ui version reported by the application or the installed package version.Source: github.com, github.com
What should I do about it?
Upgrade every instance to nginx-ui v2.5.0. No workaround is listed in the checked facts.Source: github.com, github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data