Country - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-211
Affects Drupal's Country module before 2.1.3 and from 2.2.0 before 2.2.1; the issue needs additional modules or custom code to occur. Fixed in 2.1.3 and 2.2.1.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.1.3, 2.2.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Country allows Cross-Site Scripting (XSS). This issue affects Country versions: from 0.0.0 to 2.1.3, from 2.2.0 to 2.2.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Drupal Country
From 0.0.0 · fixed in 2.1.3; From 2.2.0 · fixed in 2.2.1
References 1
drupal.org
Questions about CVE-2026-107308
What does this mean?
The Country module does not sufficiently escape user input in its autocomplete widget, which can lead to a cross-site scripting vulnerability.Source: drupal.org
Am I affected, and how do I check?
Country module versions before 2.1.3, and versions from 2.2.0 before 2.2.1. The issue cannot occur out of the box with the Country module; additional module(s) or custom code are required. Check the installed Country module version and whether any additional modules or custom code are in use.Source: drupal.org
What should I do about it?
If you use the Country module 2.2.x, upgrade to Country 2.2.1. Versions before 2.2.0 should move to 2.1.3 or later.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data