Leaflet - Moderately critical - Cross site scripting - SA-CONTRIB-2026-204
Affects Drupal Leaflet module versions below 10.4.13 when the Leaflet field formatter builds a map. Fixed in 10.4.13.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 10.4.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Leaflet module for Drupal, a contributed mapping add-on for Drupal websites, is affected by a cross-site scripting flaw that lets malicious script be stored and later run in users' browsers. This could allow an attacker to act on behalf of other users, such as stealing session data or altering page content.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Leaflet allows Stored XSS. This issue affects Leaflet versions: from 0.0.0 to 10.4.13.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Drupal Leaflet
From 0.0.0 · fixed in 10.4.13
References 1
drupal.org
Questions about CVE-2026-107265
What does this mean?
Under certain circumstances, when the Leaflet field formatter builds a map, it does not filter content titles. This leads to stored cross-site scripting in Leaflet maps.Source: drupal.org
Am I affected, and how do I check?
Leaflet module versions below 10.4.13 are affected, and only when the Leaflet field formatter builds a map under the circumstances the advisory describes. Check the installed Leaflet module version to see which release you have.Source: drupal.org
What should I do about it?
Upgrade the Leaflet module to release 10.4.13. The advisory does not list a workaround.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data