Inline Formatter Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-203
Inline Formatter Field versions before 4.2.0 are affected, and the advisory lists no extra conditions. The fix is to upgrade to 4.2.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 4.2.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Inline Formatter Field module for Drupal, a contributed add-on for the content management system, is affected by this vulnerability. An attacker could exploit the flaw to inject and run malicious code on the affected site.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Inline Formatter Field allows Code Injection. This issue affects Inline Formatter Field versions: from 0.0.0 to 4.2.0.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Drupal Inline Formatter Field
From 0.0.0 · fixed in 4.2.0
References 1
drupal.org
Questions about CVE-2026-107264
What does this mean?
The module has a server-side template injection flaw. It allows users to render protected data or execute unsafe Twig commands.Source: drupal.org
Am I affected, and how do I check?
The affected range is all versions of Inline Formatter Field before 4.2.0, with no additional conditions listed. To check, look up the installed version of Inline Formatter Field in the site's module list.Source: drupal.org
What should I do about it?
Upgrade Inline Formatter Field to 4.2.0, the version the advisory names as the fix.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data