Skip to main content
← All vulnerabilities
CVE-2026-107263EUVD-2026-113573GHSA-P5RG-H645-GVW4

Gutenberg - Moderately critical - Access bypass - SA-CONTRIB-2026-202

Affects Gutenberg module versions before 2.15.0 and 3.0.0 through 3.0.6 for roles holding the "use gutenberg" permission. Upgrade the 3.0.x line to 3.0.7.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 2.15.0, 3.0.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Gutenberg module for Drupal is affected by this vulnerability. An attacker could use direct URL access to reach content or functions they should not be permitted to view, bypassing intended access restrictions.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Incorrect Authorization vulnerability in Drupal Gutenberg allows Forceful Browsing. This issue affects Gutenberg versions: from 0.0.0 to 2.15.0, from 3.0.0 to 3.0.7.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Drupal Gutenberg

    From 0.0.0 · fixed in 2.15.0; From 3.0.0 · fixed in 3.0.7

References 1

drupal.org

FAQ

Questions about CVE-2026-107263

What does this mean?

Several editor endpoints in the Gutenberg module do not sufficiently check entity access. A user with the affected permission can reach content they should not be permitted to view.Source: drupal.org

Am I affected, and how do I check?

Gutenberg module versions before 2.15.0 and versions 3.0.0 through 3.0.6 are in scope. The relevant setup is a role with the "use gutenberg" permission, which can be checked on the role permissions page, and the installed module version can be checked on the status report or with composer show drupal/gutenberg.Source: drupal.org

What should I do about it?

Upgrade to Gutenberg 3.0.7 if running 3.0.x, and to 2.15.0 or later if running a version before 2.15.0.Source: drupal.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data