Advanced Filesystem - Moderately critical - Cross-Site Request Forgery - SA-CONTRIB-2026-217
Only affects Drupal Advanced Filesystem before 1.0.28 when the Backup submodule (advanced_filesystem_backup) is enabled. Fixed in 1.0.28.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 1.0.28
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
This vulnerability affects the Advanced Filesystem module for Drupal, a content management system add-on. An attacker could trick a logged-in user into unknowingly submitting requests that perform actions on the site without their consent.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Advanced Filesystem allows Cross Site Request Forgery. This issue affects Advanced Filesystem versions: from 0.0.0 to 1.0.28.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Drupal Advanced Filesystem
From 0.0.0 · fixed in 1.0.28
References 1
drupal.org
Questions about CVE-2026-107262
What does this mean?
The flaw is a cross-site request forgery issue. An attacker can trick a logged-in user into performing actions they did not intend through the site.Source: drupal.org
Am I affected, and how do I check?
Versions before 1.0.28 are affected, but only when the Advanced Filesystem: Backup submodule (advanced_filesystem_backup) is enabled. Check the installed module version and whether that submodule is enabled in the site's module list.Source: drupal.org
What should I do about it?
Upgrade Advanced File System to 1.0.28. The advisory names 1.0.28 as the fixed version.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data