Authenticator Login Plus (2FA) - Moderately critical - Improper authentication - SA-CONTRIB-2026-201
Affects Authenticator Login Plus (2FA) for Drupal 10 and 11 at all versions before 1.0.1, where site-wide 2FA enforcement can be bypassed. Fixed in 1.0.1.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Authenticator Login Plus (2FA) module for Drupal, which adds two-factor authentication to Drupal sites, is affected by this vulnerability. An attacker could potentially bypass the login protections and gain unauthorized access to a site's accounts.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Authenticator Login Plus (2FA) allows Authentication Bypass. This issue affects Authenticator Login Plus (2FA) versions: from 0.0.0 to 1.0.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Drupal Authenticator Login Plus (2FA)
From 0.0.0 · fixed in 1.0.1
References 1
drupal.org
Questions about CVE-2026-107261
What does this mean?
A user may be able to log in with only a password, skipping the two-factor check even when the site requires 2FA for everyone.Source: drupal.org
Am I affected, and how do I check?
Sites running Drupal 10 or 11 with the Authenticator Login Plus (2FA) module at any version before 1.0.1 are in scope. Check the installed module version on the module's admin page or with Composer to see which release is in use.Source: drupal.org
What should I do about it?
Upgrade Authenticator Login Plus (2FA) to version 1.0.1 or later.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data