Skip to main content
← All vulnerabilities
CVE-2026-107259EUVD-2026-113575GHSA-WP6M-582Q-3RFP

Linked Field - Moderately critical - Server-side template injection - SA-CONTRIB-2026-200

Linked Field versions before 1.8.0 are affected, and exposure depends on the Twig extensions installed on the site. The fix is in Linked Field 8.x-1.8.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 1.8.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Linked Field module for Drupal, a contributed add-on for the Drupal content management system, is affected by this vulnerability. An attacker could exploit improper handling of template input to inject and run code on the affected website.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Drupal Linked Field

    From 0.0.0 · fixed in 1.8.0

References 1

drupal.org

FAQ

Questions about CVE-2026-107259

What does this mean?

The bug is a server-side template injection in the Linked Field module. Depending on the Twig extensions installed on the site, it can expose site configuration values, which may include sensitive information such as API keys or credentials.Source: drupal.org

Am I affected, and how do I check?

Linked Field module versions before 1.8.0 are affected. To check, look at the installed Linked Field module version on the site's module list or with a version command, and check which Twig extensions are installed.Source: drupal.org

What should I do about it?

Update the Linked Field module for Drupal 8.x or later to 8.x-1.8 or newer.Source: drupal.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data