Inline Entity Form Dialog - Moderately critical - Access bypass - SA-CONTRIB-2026-199
Inline Entity Form Dialog versions before 1.0.6 render entity add/edit forms in an AJAX dialog without checking create or update access to the entity. Fixed in 1.0.6.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.0.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Inline Entity Form Dialog module for Drupal is affected by this vulnerability. An authorization flaw allows users to access functionality they should not be able to reach by directly requesting its address, which bypasses access controls.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Incorrect Authorization vulnerability in Drupal Inline Entity Form Dialog allows Forceful Browsing. This issue affects Inline Entity Form Dialog versions: from 0.0.0 to 1.0.6.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Drupal Inline Entity Form Dialog
From 0.0.0 · fixed in 1.0.6
References 1
drupal.org
Questions about CVE-2026-107258
What does this mean?
The module shows entity add and edit forms in an AJAX dialog for entity reference fields. It does not check whether the current user has create or update access to the entity, so those access checks are bypassed.Source: drupal.org
Am I affected, and how do I check?
Versions before 1.0.6 of the Inline Entity Form Dialog module for Drupal are affected, where the module is in use to render entity forms in a dialog for entity reference fields. Check whether the module is installed and whether its version is below 1.0.6.Source: drupal.org
What should I do about it?
Upgrade Inline Entity Form Dialog to 1.0.6. The advisory gives this upgrade for sites running Drupal 11.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data