Actstream - Critical - Access bypass - SA-CONTRIB-2026-198
Actstream versions before 2.0.1, and 2.1.0 before 2.1.1, are affected by this access bypass. Upgrade to Actstream 2.1.1 to fix it.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 2.0.1, 2.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
The Actstream module for Drupal, a tool that records and displays user activity streams, is affected by this flaw. Attackers can exploit it to reach content they should not be able to access by directly requesting pages, bypassing the intended access restrictions.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Incorrect Authorization vulnerability in Drupal Actstream allows Forceful Browsing. This issue affects Actstream versions: from 0.0.0 to 2.0.1, from 2.1.0 to 2.1.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Drupal Actstream
From 0.0.0 · fixed in 2.0.1; From 2.1.0 · fixed in 2.1.1
References 1
drupal.org
Questions about CVE-2026-107257
What does this mean?
The configuration route does not check that the user is the account owner or a user administrator. This lets the access check be bypassed, so configuration for other users' activity streams can be edited.Source: drupal.org
Am I affected, and how do I check?
Actstream versions before 2.0.1, and version 2.1.0 before 2.1.1, are affected. Check the installed Actstream version and compare it with these ranges.Source: drupal.org
What should I do about it?
Upgrade to Actstream 2.1.1. The facts list no workaround.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data