Skip to main content
← All vulnerabilities
CVE-2026-107252EUVD-2026-113580GHSA-CXWV-8H42-979J

MathJax: LaTeX for Drupal - Critical - Cross site scripting - SA-CONTRIB-2026-195

MathJax: LaTeX for Drupal versions before 4.1.2 are exposed when the module's shipped library configurations leave JavaScript inside TeX content unescaped. Fixed in 4.1.2.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 4.1.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The MathJax: LaTeX module for Drupal, a content management system plugin that renders math formulas on web pages, is affected by this vulnerability. An attacker could exploit it to inject malicious scripts into pages, potentially allowing them to run harmful code in visitors' browsers and compromise user sessions or data.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal MathJax: LaTeX for Drupal allows Cross-Site Scripting (XSS). This issue affects MathJax: LaTeX for Drupal versions: from 0.0.0 to 4.1.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Drupal MathJax: LaTeX for Drupal

    From 0.0.0 · fixed in 4.1.2

References 1

drupal.org

FAQ

Questions about CVE-2026-107252

What does this mean?

The module's bundled MathJax library configurations do not escape JavaScript written inside TeX content, so that script can run in the page as cross site scripting.Source: drupal.org

Am I affected, and how do I check?

Versions before 4.1.2 are affected when the shipped library configurations are in use. Check the installed module version on the Drupal modules page, and review the MathJax CDN URL and custom MathJax JavaScript configuration.Source: drupal.org

What should I do about it?

Upgrade MathJax: LaTeX for Drupal to 4.1.2 or later, which the advisory names as the fix.Source: drupal.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data