Entity Reference Manager (Merge entities) - Critical - Access bypass - SA-CONTRIB-2026-194
Entity Reference Manager (Merge entities) versions before 1.0.3 are affected. The fix is in 1.0.3, and the advisory gives no vendor severity rating, so only the CVSS score of 6.5 (medium) applies.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 1.0.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
The Entity Reference Manager (Merge entities) module for Drupal is affected by this vulnerability. An attacker could use forceful browsing to bypass access controls and reach functionality or content they should not be permitted to access.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Incorrect Authorization vulnerability in Drupal Entity Reference Manager (Merge entities) allows Forceful Browsing. This issue affects Entity Reference Manager (Merge entities) versions: from 0.0.0 to 1.0.3.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Drupal Entity Reference Manager (Merge entities)
From 0.0.0 · fixed in 1.0.3
References 1
drupal.org
Questions about CVE-2026-107251
What does this mean?
Users who can view content can access the entity merge functionality and delete arbitrary nodes, taxonomy terms, or media entities.Source: drupal.org
Am I affected, and how do I check?
Entity Reference Manager (Merge entities) versions before 1.0.3 are affected. Check the installed version of the module and compare it with 1.0.3.Source: drupal.org
What should I do about it?
Upgrade Entity Reference Manager to version 1.0.3. The advisory lists no workaround.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data