Block AJAX - Highly critical - PHP object injection - SA-CONTRIB-2026-192
Block AJAX versions before 3.0.2 are affected, but only on sites with Layout Builder enabled or another block plugin that handles the module's data unsafely. The fix is in 3.0.2.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 3.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
The Block AJAX module for Drupal, a content management system add-on, contains a flaw that allows attackers to inject malicious PHP objects, which could let them run arbitrary code or compromise the affected website. Sites using the module are at serious risk until it is updated to a fixed release.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Block AJAX allows Object Injection. This issue affects Block AJAX versions: from 0.0.0 to 3.0.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
- Posted on X by cve.now
Affected versions
- Drupal Block AJAX
From 0.0.0 · fixed in 3.0.2
References 1
drupal.org
Questions about CVE-2026-107249
What does this mean?
The bug allows PHP object injection through Block AJAX, which in the worst case can lead to remote code execution.Source: drupal.org
Am I affected, and how do I check?
Block AJAX versions before 3.0.2 are affected, and only on sites with Layout Builder enabled or another block plugin that handles the module's data in a potentially unsafe way. Check the installed Block AJAX version and whether Layout Builder is enabled on the site.Source: drupal.org
What should I do about it?
Upgrade block_ajax to version 3.0.2.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data